Ubuntu12.04:升級php至php5.4後imagemagick的問題

最近將php升級至5.4後,發生了找不到imagemagick extension的問題,以下是解法:

apt-get install imagemagick libmagick9-dev php5-imagick

如果遇到以下error message:

Package ‘libmagick9-dev’ has no installation candidate

那就試試這個:

apt-get install imagemagick libmagickwand-dev php5-imagick

最後再重新安裝:

pecl install imagick

記得修改php.ini

extension=imagick.so

參考文章:
http://devilsworkshop.org/tutorial/php54-imagemagick-pecl-installation/61444/

預設圖片
HC
文章: 241